$re = '/HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*/';
$str = 'HTTP/122.0 404 Not Found
Cache-Control: no-cache
Content-Type: application/json
{asad}
{cool}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);