const regex = /HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('HTTP\\\/\\d*.\\d*\\s.*\\sCache-Control:\\s.*\\s[^\\{.\\}]*', '')
const str = `HTTP/122.0 404 Not Found
Cache-Control: no-cache
Content-Type: application/json
{asad}
{cool}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}