// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*").unwrap();
let string = "HTTP/122.0 404 Not Found
Cache-Control: no-cache
Content-Type: application/json
{asad}
{cool}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}