package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*`)
var str = `HTTP/122.0 404 Not Found
Cache-Control: no-cache
Content-Type: application/json
{asad}
{cool}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}