#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\W)(c\+\+|css|c|java)(?=[^\w\+])"
Local $sString = "My favorite programming language is c++++." & @CRLF & _
"My favorite programming language is c." & @CRLF & _
"I programme in c and c++ a lot and java too!" & @CRLF & _
"I detest css." & @CRLF & _
"My favorite programming language is c++." & @CRLF & _
"My favorite programming language is c." & @CRLF & _
"My favorite programming language is c+++." & @CRLF & _
"My favorite programming language is cs." & @CRLF & _
"My favorite programming language is c. Hello world" & @CRLF & _
"My favorite programming language is c++ Hello world" & @CRLF & _
"I programme in c++ a lot!" & @CRLF & _
"My favorite programming language is c+." & @CRLF & _
"My favorite programming language is cc." & @CRLF & _
"My favorite programming language is c++!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")