const regex = /(?<=\W)(c\+\+|css|c|java)(?=[^\w\+])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\W)(c\\+\\+|css|c|java)(?=[^\\w\\+])', 'gm')
const str = `My favorite programming language is c++++.
My favorite programming language is c.
I programme in c and c++ a lot and java too!
I detest css.
My favorite programming language is c++.
My favorite programming language is c.
My favorite programming language is c+++.
My favorite programming language is cs.
My favorite programming language is c. Hello world
My favorite programming language is c++ Hello world
I programme in c++ a lot!
My favorite programming language is c+.
My favorite programming language is cc.
My favorite programming language is c++!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}