using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\W)(c\+\+|css|c|java)(?=[^\w\+])";
string input = @"My favorite programming language is c++++.
My favorite programming language is c.
I programme in c and c++ a lot and java too!
I detest css.
My favorite programming language is c++.
My favorite programming language is c.
My favorite programming language is c+++.
My favorite programming language is cs.
My favorite programming language is c. Hello world
My favorite programming language is c++ Hello world
I programme in c++ a lot!
My favorite programming language is c+.
My favorite programming language is cc.
My favorite programming language is c++!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}