use strict;
my $str = 'My favorite programming language is c++++.
My favorite programming language is c.
I programme in c and c++ a lot and java too!
I detest css.
My favorite programming language is c++.
My favorite programming language is c.
My favorite programming language is c+++.
My favorite programming language is cs.
My favorite programming language is c. Hello world
My favorite programming language is c++ Hello world
I programme in c++ a lot!
My favorite programming language is c+.
My favorite programming language is cc.
My favorite programming language is c++!';
my $regex = qr/(?<=\W)(c\+\+|css|c|java)(?=[^\w\+])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}