import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\W)(c\\+\\+|css|c|java)(?=[^\\w\\+])";
final String string = "My favorite programming language is c++++.\n"
+ "My favorite programming language is c.\n"
+ "I programme in c and c++ a lot and java too!\n"
+ "I detest css.\n"
+ "My favorite programming language is c++.\n"
+ "My favorite programming language is c.\n"
+ "My favorite programming language is c+++.\n"
+ "My favorite programming language is cs.\n"
+ "My favorite programming language is c. Hello world\n"
+ "My favorite programming language is c++ Hello world\n"
+ "I programme in c++ a lot!\n"
+ "My favorite programming language is c+.\n"
+ "My favorite programming language is cc.\n"
+ "My favorite programming language is c++!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}