#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<={% hi %})\n*.*\n*(?:{% endhi %})*?"
Local $sString = "{% hi %}" & @CRLF & _
"fsda" & @CRLF & _
"{% endhi %}" & @CRLF & _
"" & @CRLF & _
"{% hi %}" & @CRLF & _
"fsda" & @CRLF & _
"{% endhi %}"
Local $sSubst = "huahuahauhauhauhauhauhauahuauu"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)