re = /(?<={% hi %})\n*.*\n*(?:{% endhi %})*?/
str = '{% hi %}
fsda
{% endhi %}
{% hi %}
fsda
{% endhi %}'
subst = 'huahuahauhauhauhauhauhauahuauu'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result