import Foundation
let pattern = #"(?<={% hi %})\n*.*\n*(?:{% endhi %})*?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{% hi %}
fsda
{% endhi %}
{% hi %}
fsda
{% endhi %}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"huahuahauhauhauhauhauhauahuauu"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)