using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<={% hi %})\n*.*\n*(?:{% endhi %})*?";
string substitution = @"huahuahauhauhauhauhauhauahuauu";
string input = @"{% hi %}
fsda
{% endhi %}
{% hi %}
fsda
{% endhi %}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}