import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\{% hi %\\})\\n*.*\\n*(?:\\{% endhi %\\})*?";
final String string = "{% hi %}\n"
+ "fsda\n"
+ "{% endhi %}\n\n"
+ "{% hi %}\n"
+ "fsda\n"
+ "{% endhi %}";
final String subst = "huahuahauhauhauhauhauhauahuauu";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}