$re = '/(?<={% hi %})\n*.*\n*(?:{% endhi %})*?/';
$str = '{% hi %}
fsda
{% endhi %}
{% hi %}
fsda
{% endhi %}';
$subst = "huahuahauhauhauhauhauhauahuauu";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;