using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*if.*(*SKIP)(*FAIL)|\$\w+\s*=.* (and|or) .*";
string input = @"$is_valid = $is_active and !$is_deleted;
if($is_active and !$is_deleted) {}
$is_valid = (($cost + $tax) > 20) and ($tax < 3);";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}