package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*if.*(*SKIP)(*FAIL)|\$\w+\s*=.* (and|or) .*`)
var str = `$is_valid = $is_active and !$is_deleted;
if($is_active and !$is_deleted) {}
$is_valid = (($cost + $tax) > 20) and ($tax < 3);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}