import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*if.*(*SKIP)(*FAIL)|\\$\\w+\\s*=.* (and|or) .*";
final String string = "$is_valid = $is_active and !$is_deleted;\n"
+ "if($is_active and !$is_deleted) {}\n"
+ "$is_valid = (($cost + $tax) > 20) and ($tax < 3);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}