$re = '/^\s*if.*(*SKIP)(*FAIL)|\$\w+\s*=.* (and|or) .*/';
$str = '$is_valid = $is_active and !$is_deleted;
if($is_active and !$is_deleted) {}
$is_valid = (($cost + $tax) > 20) and ($tax < 3);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);