re = /^\s*if.*(*SKIP)(*FAIL)|\$\w+\s*=.* (and|or) .*/
str = '$is_valid = $is_active and !$is_deleted;
if($is_active and !$is_deleted) {}
$is_valid = (($cost + $tax) > 20) and ($tax < 3);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end