#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9][0-9]*(\.[0-9]*[1-9])?|0\.[0-9]*[1-9])"
Local $sString = "GOOD:" & @CRLF & _
".01" & @CRLF & _
".1" & @CRLF & _
"0.01" & @CRLF & _
"0.1" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"10.1" & @CRLF & _
"10.11" & @CRLF & _
"105.1" & @CRLF & _
"999.99" & @CRLF & _
"88.00" & @CRLF & _
"" & @CRLF & _
"BAD:" & @CRLF & _
"12345678.54" & @CRLF & _
"00564.5412" & @CRLF & _
"00.451" & @CRLF & _
"1." & @CRLF & _
",25" & @CRLF & _
"..25" & @CRLF & _
"0025" & @CRLF & _
"01" & @CRLF & _
"00,25" & @CRLF & _
"0" & @CRLF & _
".0" & @CRLF & _
"0.001" & @CRLF & _
"999.001" & @CRLF & _
"e123.12" & @CRLF & _
"1000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")