// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9][0-9]*(\.[0-9]*[1-9])?|0\.[0-9]*[1-9])").unwrap();
let string = "GOOD:
.01
.1
0.01
0.1
1
10
10.1
10.11
105.1
999.99
88.00
BAD:
12345678.54
00564.5412
00.451
1.
,25
..25
0025
01
00,25
0
.0
0.001
999.001
e123.12
1000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}