package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9][0-9]*(\.[0-9]*[1-9])?|0\.[0-9]*[1-9])`)
var str = `GOOD:
.01
.1
0.01
0.1
1
10
10.1
10.11
105.1
999.99
88.00
BAD:
12345678.54
00564.5412
00.451
1.
,25
..25
0025
01
00,25
0
.0
0.001
999.001
e123.12
1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}