import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9][0-9]*(\\.[0-9]*[1-9])?|0\\.[0-9]*[1-9])";
final String string = "GOOD:\n"
+ ".01\n"
+ ".1\n"
+ "0.01\n"
+ "0.1\n"
+ "1\n"
+ "10\n"
+ "10.1\n"
+ "10.11\n"
+ "105.1\n"
+ "999.99\n"
+ "88.00\n\n"
+ "BAD:\n"
+ "12345678.54\n"
+ "00564.5412\n"
+ "00.451\n"
+ "1.\n"
+ ",25\n"
+ "..25\n"
+ "0025\n"
+ "01\n"
+ "00,25\n"
+ "0\n"
+ ".0\n"
+ "0.001\n"
+ "999.001\n"
+ "e123.12\n"
+ "1000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}