use strict;
my $str = 'GOOD:
.01
.1
0.01
0.1
1
10
10.1
10.11
105.1
999.99
88.00
BAD:
12345678.54
00564.5412
00.451
1.
,25
..25
0025
01
00,25
0
.0
0.001
999.001
e123.12
1000';
my $regex = qr/^([1-9][0-9]*(\.[0-9]*[1-9])?|0\.[0-9]*[1-9])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}