using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([1-9][0-9]*(\.[0-9]*[1-9])?|0\.[0-9]*[1-9])";
string input = @"GOOD:
.01
.1
0.01
0.1
1
10
10.1
10.11
105.1
999.99
88.00
BAD:
12345678.54
00564.5412
00.451
1.
,25
..25
0025
01
00,25
0
.0
0.001
999.001
e123.12
1000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}