const regex = /^([1-9][0-9]*(\.[0-9]*[1-9])?|0\.[0-9]*[1-9])/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9][0-9]*(\\.[0-9]*[1-9])?|0\\.[0-9]*[1-9])', 'mg')
const str = `GOOD:
.01
.1
0.01
0.1
1
10
10.1
10.11
105.1
999.99
88.00
BAD:
12345678.54
00564.5412
00.451
1.
,25
..25
0025
01
00,25
0
.0
0.001
999.001
e123.12
1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}