package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<input class="form-control" type="text" id="([^"]+)">`)
var str = `<input class="form-control" type="text" id="ogwb">`
var substitution = "<input class="form-control" type="text" id="\1" name="\1" value="<?php echo htmlspecialchars($_POST['\1']); ?>">"
fmt.Println(re.ReplaceAllString(str, substitution))
}