use strict;
my $str = '<input class="form-control" type="text" id="ogwb">';
my $regex = qr/<input class="form-control" type="text" id="([^"]+)">/p;
my $subst = '<input class="form-control" type="text" id="\\1" name="\\1" value="<?php echo htmlspecialchars($_POST[\'\\1\']); ?>">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";