re = /<input class="form-control" type="text" id="([^"]+)">/
str = '<input class="form-control" type="text" id="ogwb">'
subst = '<input class="form-control" type="text" id="\\1" name="\\1" value="<?php echo htmlspecialchars($_POST[\'\\1\']); ?>">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result