// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<input class="form-control" type="text" id="([^"]+)">"#).unwrap();
let string = "<input class=\"form-control\" type=\"text\" id=\"ogwb\">";
let substitution = "<input class=\"form-control\" type=\"text\" id=\"\\1\" name=\"\\1\" value=\"<?php echo htmlspecialchars($_POST['\\1']); ?>\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}