$re = '/<input class="form-control" type="text" id="([^"]+)">/';
$str = '<input class="form-control" type="text" id="ogwb">';
$subst = "<input class=\"form-control\" type=\"text\" id=\"\1\" name=\"\1\" value=\"<?php echo htmlspecialchars($_POST['\1']); ?>\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;