const regex = /<input class="form-control" type="text" id="([^"]+)">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input class="form-control" type="text" id="([^"]+)">', 'g')
const str = `<input class="form-control" type="text" id="ogwb">`;
const subst = `<input class="form-control" type="text" id="\1" name="\1" value="<?php echo htmlspecialchars($_POST['\1']); ?>">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);