# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\pL\W+)\1+/$1/gu;t' <<< "Jim G G Bob
Jim G. G. Bob
Tom H H H Ford
Sarah H Howard"