$re = '/\b(\pL\W+)\1+/u';
$str = 'Jim G G Bob
Jim G. G. Bob
Tom H H H Ford
Sarah H Howard';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;