re = /\b(\pL\W+)\1+/
str = 'Jim G G Bob
Jim G. G. Bob
Tom H H H Ford
Sarah H Howard'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result