#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)\b(\pL\W+)\1+"
Local $sString = "Jim G G Bob" & @CRLF & _
"Jim G. G. Bob" & @CRLF & _
"Tom H H H Ford" & @CRLF & _
"Sarah H Howard"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)