const regex = /\b(\pL\W+)\1+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\pL\\W+)\\1+', 'gu')
const str = `Jim G G Bob
Jim G. G. Bob
Tom H H H Ford
Sarah H Howard`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);