using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\pL\W+)\1+";
string substitution = @"$1";
string input = @"Jim G G Bob
Jim G. G. Bob
Tom H H H Ford
Sarah H Howard";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}