# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("name":\ "[A-Z][a-z]+|(?<!^)\G)([A-Z][a-z]+)/\1 \2/gm;t' <<< "\"name\": \"CapitalCaseWords\"
\"name\": \"AnotherStringSentence\"
\"ThisStringShouldntBeReplaced\""