re = /("name":\ "[A-Z][a-z]+|(?<!^)\G)([A-Z][a-z]+)/m
str = '"name": "CapitalCaseWords"
"name": "AnotherStringSentence"
"ThisStringShouldntBeReplaced"'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result