$re = '/("name":\ "[A-Z][a-z]+|(?<!^)\G)([A-Z][a-z]+)/m';
$str = '"name": "CapitalCaseWords"
"name": "AnotherStringSentence"
"ThisStringShouldntBeReplaced"';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;