#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)("name":\ "[A-Z][a-z]+|(?<!^)\G)([A-Z][a-z]+)"
Local $sString = ""name": "CapitalCaseWords"" & @CRLF & _
""name": "AnotherStringSentence"" & @CRLF & _
""ThisStringShouldntBeReplaced""
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)