using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""name"":\ ""[A-Z][a-z]+|(?<!^)\G)([A-Z][a-z]+)";
string substitution = @"\1 \2";
string input = @"""name"": ""CapitalCaseWords""
""name"": ""AnotherStringSentence""
""ThisStringShouldntBeReplaced""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}