import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"name\":\\ \"[A-Z][a-z]+|(?<!^)\\G)([A-Z][a-z]+)";
final String string = "\"name\": \"CapitalCaseWords\"\n"
+ "\"name\": \"AnotherStringSentence\"\n"
+ "\"ThisStringShouldntBeReplaced\"";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}