# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^('''\n?(?:.*?)(?:\n.*)*)(?!'''\n?)$/$1\n'''/g;t' <<< "'''
IF OPENING DELIMITER IS NOT MATCHED,
ADD CLOSING DELIMITER TO MATCH
sad
fsd
f
sdaf
sdaf
sdf
sdaf
sdf
dsfa
sdf
aasdf
dsf"