#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^('''\n?(?:.*?)(?:\n.*)*)(?!'''\n?)$"
Local $sString = "'''" & @CRLF & _
"IF OPENING DELIMITER IS NOT MATCHED," & @CRLF & _
"ADD CLOSING DELIMITER TO MATCH" & @CRLF & _
"sad" & @CRLF & _
"fsd" & @CRLF & _
"f" & @CRLF & _
"sdaf" & @CRLF & _
"sdaf" & @CRLF & _
"sdf" & @CRLF & _
"sdaf" & @CRLF & _
"sdf" & @CRLF & _
"dsfa" & @CRLF & _
"sdf" & @CRLF & _
"aasdf" & @CRLF & _
"dsf"
Local $sSubst = "$1\n'''"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)