import Foundation
let pattern = #"^('''\n?(?:.*?)(?:\n.*)*)(?!'''\n?)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'''
IF OPENING DELIMITER IS NOT MATCHED,
ADD CLOSING DELIMITER TO MATCH
sad
fsd
f
sdaf
sdaf
sdf
sdaf
sdf
dsfa
sdf
aasdf
dsf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n'''"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)