use strict;
my $str = '\'\'\'
IF OPENING DELIMITER IS NOT MATCHED,
ADD CLOSING DELIMITER TO MATCH
sad
fsd
f
sdaf
sdaf
sdf
sdaf
sdf
dsfa
sdf
aasdf
dsf';
my $regex = qr/^('''\n?(?:.*?)(?:\n.*)*)(?!'''\n?)$/p;
my $subst = '$1\\n\'\'\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";