$re = '/^(\'\'\'\n?(?:.*?)(?:\n.*)*)(?!\'\'\'\n?)$/';
$str = '\'\'\'
IF OPENING DELIMITER IS NOT MATCHED,
ADD CLOSING DELIMITER TO MATCH
sad
fsd
f
sdaf
sdaf
sdf
sdaf
sdf
dsfa
sdf
aasdf
dsf';
$subst = "$1\n'''";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;